import Foundation
let pattern = #"FindMe"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://example.com/FindMe/john
http://example.com/FindMe/Jill
http://example.com/FindMe/boo/who?=d
http://example.com/FindMe/adamdasfaam
http://example.com/FindMe/ddafdf/adfkhjhad/adsfjd/jddhadk
http://example.com/blahblah
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)