re = /FindMe/
str = 'http://example.com/FindMe/john
http://example.com/FindMe/Jill
http://example.com/FindMe/boo/who?=d
http://example.com/FindMe/adamdasfaam
http://example.com/FindMe/ddafdf/adfkhjhad/adsfjd/jddhadk
http://example.com/blahblah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end