package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^|\D(\d{6})\D|$`)
var str = `teste 1 n°123456 fim do teste
teste 2 n°7890123 fim do teste
132567
texto com numero no fim123456
texto222333texto
texto2223334texto`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}