re = /^|\D(\d{6})\D|$/m
str = 'teste 1 n°123456 fim do teste
teste 2 n°7890123 fim do teste
132567
texto com numero no fim123456
texto222333texto
texto2223334texto'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end