// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^|\D(\d{6})\D|$").unwrap();
let string = "teste 1 n°123456 fim do teste
teste 2 n°7890123 fim do teste
132567
texto com numero no fim123456
texto222333texto
texto2223334texto";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}