package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ID[ \t]*:[ \t]*(.*)\r?\n`)
var str = `ID :
Level: info
ID:
Rule name: an id
Severity: Medium
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}