$re = '/^ID[ \t]*:[ \t]*(.*)\r?\n/m';
$str = 'ID :
Level: info
ID:
Rule name: an id
Severity: Medium
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);