re = /^ID[ \t]*:[ \t]*(.*)\r?\n/m
str = 'ID :
Level: info
ID:
Rule name: an id
Severity: Medium
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end