using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[^{}\n]*{[^}\n]*})*[^{}\n]*$";
string input = @"{a} {boy} lives here
{a} boy {lives} here
a {boy} lives here
a boy lives here
a boy lives here }
{{a} boy lives here}
a boy {{lives}} here
a boy {lives} here {
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}