re = /^(?:[^{}\n]*{[^}\n]*})*[^{}\n]*$/m
str = '{a} {boy} lives here
{a} boy {lives} here
a {boy} lives here
a boy lives here
a boy lives here }
{{a} boy lives here}
a boy {{lives}} here
a boy {lives} here {
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end