using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!--.*?-->";
string substitution = @"";
string input = @"blablabla
<teste>teste</teste>
etc
<!-- Assinatura principal -->
<x>mais conteúdo</x>
<!-- [if gte mso 9]><xml> <o:OfficeDocumentSettings> <o:AllowPNG /> </o:OfficeDocumentSettings> </xml><![endif]-->
blablabla
<!---->
<!--
-->
<p>lorem ipsum</p>
<!-- <!-- fad ->----->";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}