package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)<!--.*?-->`)
var str = `blablabla
<teste>teste</teste>
etc
<!-- Assinatura principal -->
<x>mais conteúdo</x>
<!-- [if gte mso 9]><xml> <o:OfficeDocumentSettings> <o:AllowPNG /> </o:OfficeDocumentSettings> </xml><![endif]-->
blablabla
<!---->
<!--
-->
<p>lorem ipsum</p>
<!-- <!-- fad ->----->`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}