const regex = new RegExp('(https?:\\/\\/[^\\/]+)\\/[^\\/]+(\\/film\\/[^\\/]+)(?:\\/\\d+)?', 'gm')
const str = `https://letterboxd.com/username/film/sometitle/
https://letterboxd.com/username59/film/sometitle/1/
https://letterboxd.com/username59/film/sometitle/2/`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);