$re = '~(https?:\/\/[^\/]+)\/[^\/]+(\/film\/[^\/]+)(?:\/\d+)?~m';
$str = 'https://letterboxd.com/username/film/sometitle/
https://letterboxd.com/username59/film/sometitle/1/
https://letterboxd.com/username59/film/sometitle/2/';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;