import re
regex = re.compile(r"(https?:\/\/[^\/]+)\/[^\/]+(\/film\/[^\/]+)(?:\/\d+)?", flags=re.MULTILINE)
test_str = ("https://letterboxd.com/username/film/sometitle/\n"
"https://letterboxd.com/username59/film/sometitle/1/\n"
"https://letterboxd.com/username59/film/sometitle/2/")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)