using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^15\.0[0-3]|^14\.";
string input = @"15.03.005.0
15.04.005.0
16.00.000.0
14.10.004.0
16.14.000.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}