re = /^15\.0[0-3]|^14\./m
str = '15.03.005.0
15.04.005.0
16.00.000.0
14.10.004.0
16.14.000.0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end