// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^15\.0[0-3]|^14\.").unwrap();
let string = "15.03.005.0
15.04.005.0
16.00.000.0
14.10.004.0
16.14.000.0";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}