import Foundation
let pattern = #"^(.+)([A-Z]{3}:)(\s+)([A-Z0-9|=]+)(.*\S\s*?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2019-05-08T20:55:04.913701+00:00 CEF: 0|CISCO|ASA||302013|Built outbound TCP connection|Low| eventId=17363056 externalId=116395008 proto=TCP
CEF:0|CISCO|ASA||302013|Built outbound TCP connection|Low| eventId=17363056 externalId=116395008 proto=TCP
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2\4\5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)