const regex = /^(.*\S\R)(\d+)(\R0)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*\\S\\R)(\\d+)(\\R0)$', 'gm')
const str = `ABC
5
0
gdfgdfg
-----------
GHN
3
0
ffffffff
fffff
ffff
trte
-------------
H
1
0
----------------`;
const subst = `$1$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);