$re = '/^(.*\S\R)(\d+)(\R0)$/m';
$str = 'ABC
5
0
gdfgdfg
-----------
GHN
3
0
ffffffff
fffff
ffff
trte
-------------
H
1
0
----------------';
$subst = "$1$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;