import re
regex = re.compile(r"^(.*\S\R)(\d+)(\R0)$", flags=re.MULTILINE)
test_str = ("ABC\n"
"5\n"
"0\n"
"gdfgdfg\n"
"-----------\n"
"GHN\n"
"3\n"
"0\n"
"ffffffff\n"
"fffff\n"
"ffff\n"
"trte\n"
"-------------\n"
"H\n"
"1\n"
"0\n"
"----------------")
subst = "$1$3"
result = regex.sub(subst, test_str)
if result:
print(result)