using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@if\((.*?)\)\s+{{((?:[^{}]|(?R))*)}}";
string input = @"
@if(topLevel)
{{
<form method=""post"">
@if(bottomLevel)
{{
<input>
}}
</form>
}}
@if(topLevel)
{{
<form method=""post"">
@if(bottomLevel)
{{
@if(bottomLevel)
{{
<input>
}}
}}
</form>
}}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}