re = /@if\((.*?)\)\s+{{((?:[^{}]|(?R))*)}}/
str = '
@if(topLevel)
{{
<form method="post">
@if(bottomLevel)
{{
<input>
}}
</form>
}}
@if(topLevel)
{{
<form method="post">
@if(bottomLevel)
{{
@if(bottomLevel)
{{
<input>
}}
}}
</form>
}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end