$re = '/@if\((.*?)\)\s+{{((?:[^{}]|(?R))*)}}/';
$str = '
@if(topLevel)
{{
<form method="post">
@if(bottomLevel)
{{
<input>
}}
</form>
}}
@if(topLevel)
{{
<form method="post">
@if(bottomLevel)
{{
@if(bottomLevel)
{{
<input>
}}
}}
</form>
}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);