#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?\Wfoo\W.*?$"
Local $sString = "foo here " & @CRLF & _
"" & @CRLF & _
"If Request.QueryString("bar") <> "" Then" & @CRLF & _
" Set bar= foo("baz")" & @CRLF & _
"Else" & @CRLF & _
" Set bar= foo("baz2")" & @CRLF & _
"End If" & @CRLF & _
"" & @CRLF & _
"and another foo"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")