re = /^.*?\Wfoo\W.*?$/m
str = 'foo here
If Request.QueryString("bar") <> "" Then
Set bar= foo("baz")
Else
Set bar= foo("baz2")
End If
and another foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end