import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?\\Wfoo\\W.*?$";
final String string = "foo here \n\n"
+ "If Request.QueryString(\"bar\") <> \"\" Then\n"
+ " Set bar= foo(\"baz\")\n"
+ "Else\n"
+ " Set bar= foo(\"baz2\")\n"
+ "End If\n\n"
+ "and another foo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}