use strict;
my $str = '<iframe ';
my $regex = qr/^(<[A-Za-z-]+)/mp;
my $subst = '$1 my-attr';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";