$re = '/^(<[A-Za-z-]+)/m';
$str = '<iframe ';
$subst = "$1 my-attr";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;