#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m):06..0201213(5[C-F]|[6-9A-C].|D[0-3])."
Local $sString = ":06800201212E39" & @CRLF & _
":06800201212E40" & @CRLF & _
":06800201212EA5" & @CRLF & _
":06800201212F00" & @CRLF & _
":06800201212FFF" & @CRLF & _
":06800201213000" & @CRLF & _
":068002012134FF" & @CRLF & _
":06800201213500" & @CRLF & _
":0680020121359F" & @CRLF & _
":068002012135A1" & @CRLF & _
":068002012135BF" & @CRLF & _
":068002012135C0" & @CRLF & _
":068002012136A1" & @CRLF & _
":06800201213A01" & @CRLF & _
":06800201213CFF" & @CRLF & _
":06800201213D01" & @CRLF & _
":06800201213D3F" & @CRLF & _
":06800201213D40"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")