const regex = /:06..0201213(5[C-F]|[6-9A-C].|D[0-3])./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':06..0201213(5[C-F]|[6-9A-C].|D[0-3]).', 'gm')
const str = `:06800201212E39
:06800201212E40
:06800201212EA5
:06800201212F00
:06800201212FFF
:06800201213000
:068002012134FF
:06800201213500
:0680020121359F
:068002012135A1
:068002012135BF
:068002012135C0
:068002012136A1
:06800201213A01
:06800201213CFF
:06800201213D01
:06800201213D3F
:06800201213D40`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}