import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":06..0201213(5[C-F]|[6-9A-C].|D[0-3]).";
final String string = ":06800201212E39\n"
+ ":06800201212E40\n"
+ ":06800201212EA5\n"
+ ":06800201212F00\n"
+ ":06800201212FFF\n"
+ ":06800201213000\n"
+ ":068002012134FF\n"
+ ":06800201213500\n"
+ ":0680020121359F\n"
+ ":068002012135A1\n"
+ ":068002012135BF\n"
+ ":068002012135C0\n"
+ ":068002012136A1\n"
+ ":06800201213A01\n"
+ ":06800201213CFF\n"
+ ":06800201213D01\n"
+ ":06800201213D3F\n"
+ ":06800201213D40";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}