using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((\+34[\s])|(\(\+34\)[\s]?))?[9|8|7|6][0-9]{2}([0-9]{6}|([\s][0-9]{3}){2}|([\s][0-9]{2}){3})$";
string input = @"(+34) 666 66 66 66";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}