re = /^((\+34[\s])|(\(\+34\)[\s]?))?[9|8|7|6][0-9]{2}([0-9]{6}|([\s][0-9]{3}){2}|([\s][0-9]{2}){3})$/
str = '(+34) 666 66 66 66'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end