package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((\+34[\s])|(\(\+34\)[\s]?))?[9|8|7|6][0-9]{2}([0-9]{6}|([\s][0-9]{3}){2}|([\s][0-9]{2}){3})$`)
var str = `(+34) 666 66 66 66`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}