use strict;
my $str = 'string1 string1 string2 string1 more
text string3 string1 string1 string2 string1 strin4 string1 string3';
my $regex = qr/string1(?:(?!string1|string2)[\s\S\r])*?string3/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}