$re = '/string1(?:(?!string1|string2)[\s\S\r])*?string3/';
$str = 'string1 string1 string2 string1 more
text string3 string1 string1 string2 string1 strin4 string1 string3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);