import Foundation
let pattern = #"string1(?:(?!string1|string2)[\s\S\r])*?string3"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
string1 string1 string2 string1 more
text string3 string1 string1 string2 string1 strin4 string1 string3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)