import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(')([a-z])";
final String string = " 'full_name' => 'نام و نام خانوادگی',\n"
+ " 'mobile' => 'شماره تلفن همراه',\n"
+ " 'email' => 'ایمیل',\n"
+ " 'password' => 'رمز عبور',\n"
+ " 'first_name' => 'نام',\n"
+ " 'last_name' => 'نام خانوادگی',\n"
+ " 'father_name' => 'نام پدر',\n"
+ " 'national_code' => 'کد ملی',\n"
+ " 'bs_number' => 'شماره شناسنامه',\n"
+ " 'bs_prefix_alpha' => 'حروف سریال شناسنامه',\n"
+ " 'bs_prefix_num' => 'اعداد سریال شناسنامه',\n"
+ " 'bs_serial' => 'شماره سریال شناسنامه',\n"
+ " 'birthday' => 'تاریخ تولد',\n"
+ " 'issue_place' => 'محل صدور',\n"
+ " 'gender' => 'جنسیت',\n"
+ " 'marital_status' => 'وضعیت تاهل',\n"
+ " 'postal_code' => 'کد پستی',\n"
+ " 'home_phone' => 'تلفن منزل',\n"
+ " 'fax' => 'فکس',\n"
+ " 'province' => 'استان',\n"
+ " 'city' => 'شهر',\n"
+ " 'address' => 'آدرس',\n"
+ " 'contact_type' => 'نوع آدرس',\n"
+ " 'country' => 'کشور',\n"
+ " 'company_name' => 'نام محل کار',\n"
+ " 'phone' => 'شماره ثابت',\n"
+ " 'account_type' => 'نوع حساب',\n"
+ " 'bank' => 'نام بانک',\n"
+ " 'branch_name' => 'نام شعبه',\n"
+ " 'branch_code' => 'کد شعبه',\n"
+ " 'branch_city' => 'شهر محل شعبه',\n"
+ " 'account_number' => 'شماره حساب',\n"
+ " 'owner_name' => 'نام دارنده حساب',\n"
+ " 'iban' => 'شماره شبا',\n"
+ " 'document_type' => 'نوع مدرک',\n"
+ " 'file_name' => 'فایل',\n"
+ " 'trading_code' => 'کد سهامداری',\n"
+ " 'sejam_code' => 'کد سجام',\n"
+ " 'old_bs' => 'گزینه شناسنامه نو',\n"
+ " 'data' => 'داده ها',\n"
+ " 'user_type' => 'نوع کاربر',";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}