const regex = /(')([a-z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\')([a-z])', 'gm')
const str = ` 'full_name' => 'نام و نام خانوادگی',
'mobile' => 'شماره تلفن همراه',
'email' => 'ایمیل',
'password' => 'رمز عبور',
'first_name' => 'نام',
'last_name' => 'نام خانوادگی',
'father_name' => 'نام پدر',
'national_code' => 'کد ملی',
'bs_number' => 'شماره شناسنامه',
'bs_prefix_alpha' => 'حروف سریال شناسنامه',
'bs_prefix_num' => 'اعداد سریال شناسنامه',
'bs_serial' => 'شماره سریال شناسنامه',
'birthday' => 'تاریخ تولد',
'issue_place' => 'محل صدور',
'gender' => 'جنسیت',
'marital_status' => 'وضعیت تاهل',
'postal_code' => 'کد پستی',
'home_phone' => 'تلفن منزل',
'fax' => 'فکس',
'province' => 'استان',
'city' => 'شهر',
'address' => 'آدرس',
'contact_type' => 'نوع آدرس',
'country' => 'کشور',
'company_name' => 'نام محل کار',
'phone' => 'شماره ثابت',
'account_type' => 'نوع حساب',
'bank' => 'نام بانک',
'branch_name' => 'نام شعبه',
'branch_code' => 'کد شعبه',
'branch_city' => 'شهر محل شعبه',
'account_number' => 'شماره حساب',
'owner_name' => 'نام دارنده حساب',
'iban' => 'شماره شبا',
'document_type' => 'نوع مدرک',
'file_name' => 'فایل',
'trading_code' => 'کد سهامداری',
'sejam_code' => 'کد سجام',
'old_bs' => 'گزینه شناسنامه نو',
'data' => 'داده ها',
'user_type' => 'نوع کاربر',`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}