package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sm)(?:^|\t)
(
[^\t\n]+
(?=.*
(^[ ]{3,})"
)
)
`)
var str = `База Базовая добыча (вЯк 8) 42370
Бурение well_obj1_1_prod (вЯк 8) 42370
Бурение well_obj1_1_inj (вЯк 8) 42430
"`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}