import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\t)\n"
+ "(\n"
+ "[^\\t\\n]+\n"
+ "(?=.*\n"
+ " (^[ ]{3,})\"\n"
+ ")\n"
+ ")\n";
final String string = "База Базовая добыча (вЯк 8) 42370\n"
+ "Бурение well_obj1_1_prod (вЯк 8) 42370\n"
+ "Бурение well_obj1_1_inj (вЯк 8) 42430\n"
+ " \"";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}