import re
regex = re.compile(r"""
(?:^|\t)
(
[^\t\n]+
(?=.*
(^[ ]{3,})"
)
)
""", flags=re.VERBOSE | re.DOTALL | re.MULTILINE)
test_str = ("База Базовая добыча (вЯк 8) 42370\n"
"Бурение well_obj1_1_prod (вЯк 8) 42370\n"
"Бурение well_obj1_1_inj (вЯк 8) 42430\n"
" \"")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)