package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<a?)?:\w+:(\d{18}>)?`)
var str = `<:ok_check:652867697494720533>
<a:aGES_Kek:741032442814791702>
:123:
123456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}