const regex = /(<a?)?:\w+:(\d{18}>)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<a?)?:\\w+:(\\d{18}>)?', 'g')
const str = `<:ok_check:652867697494720533>
<a:aGES_Kek:741032442814791702>
:123:
123456`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}