import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a?)?:\\w+:(\\d{18}>)?";
final String string = "<:ok_check:652867697494720533>\n"
+ "<a:aGES_Kek:741032442814791702>\n"
+ ":123:\n"
+ "123456";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}