#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[A-Z][a-z]+[,\s&]*|[A-Z]\.),?"
Local $sString = "Kraus, Fritz R., (1968) 146" & @CRLF & _
" " & @CRLF & _
"Owen, David I., (2013) 1156" & @CRLF & _
"" & @CRLF & _
"Dalley, Stephanie & Yoffee, Norman, (1991) 001" & @CRLF & _
"" & @CRLF & _
"De Graef, (2016) p. 32 no. 9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")