import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\"(product\\stype[1234]\\(\\d+(?:\\.\\d+)?\\))\\s*(:.*?)?\"$";
final String string = "\"product type1(0)\"\n"
+ "\"product type2(923)\"\n"
+ "\"product type3(10)\"\n"
+ "\"product type4(110.023) :here is a comment. It always starts with a semicolon\"\n"
+ "\"product type1(14.4):comments can be just after product entry\"\n"
+ "\"product type1(10.0) : spaces are not relevant\"\n"
+ "\"product type1(0000.01) : this kind of entry is acceptable\"\n\n"
+ "\"product type1(asd)\"\n"
+ "\"product type1(12a3.02)\" \n"
+ "\"product type2(0.)\"\n"
+ "\"product type2(0.123.123)\"\n"
+ "\"product type2(0...)\"\n"
+ "\"product type3(0.asd)\"\n"
+ "\"product type4(10)\" comment doesn't start with a semicolon\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}