# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\"(product\stype[1234]\(\d+(?:\.\d+)?\))\s*(:.*?)?\"$"
test_str = ("\"product type1(0)\"\n"
"\"product type2(923)\"\n"
"\"product type3(10)\"\n"
"\"product type4(110.023) :here is a comment. It always starts with a semicolon\"\n"
"\"product type1(14.4):comments can be just after product entry\"\n"
"\"product type1(10.0) : spaces are not relevant\"\n"
"\"product type1(0000.01) : this kind of entry is acceptable\"\n\n"
"\"product type1(asd)\"\n"
"\"product type1(12a3.02)\" \n"
"\"product type2(0.)\"\n"
"\"product type2(0.123.123)\"\n"
"\"product type2(0...)\"\n"
"\"product type3(0.asd)\"\n"
"\"product type4(10)\" comment doesn't start with a semicolon\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.